• Capacitive Touch Display - Features a 4-inch fingerprint-proof multi-touch screen with a clear user interface to manage meetings effortlessly
  • Spill-Resistant Fabric - Built with a sophisticated black acoustic fabric housing designed to repel water, oil, and stains for long-lasting durability
  • Omnidirectional Voice Capture - Utilises a 7-microphone array (6 for voice pickup and 1 for noise cancellation) to achieve 360-degree coverage across a 20-foot range
  • Flexible BYOD Integration - Connects seamlessly with personal smartphones, tablets, or computers via Bluetooth or USB to blend mobile & IP calls into a unified hybrid UC session
  • Direct Meeting Control - Supports 5-way conferencing, intuitive one-button meeting launches via the Linux-based UI, and ingenious hidden cable routing

*Please note that The Yealink CP925 is PoE - Power over Ethernet if PoE isnt Available a Power Supply Unit (PSU) will need to be Purchased

Yealink CP925 Touch Sensitive HD IP Conference Phone

Yealink
PMC Product code
21653
Manufacturer's Product Code
CP925
In Stock
£145.00 £174.00
VisaMastercardAmerican ExpressMaestroPayPalKlarnaAppleGoogle Pay

Free shipping when you spend over £150*Free shipping when you spend over £150

DHL Premium shippingDHL Premium shipping

*UK Mainland Only. Some locations and products not eligible due to weight & size. Courier company not guaranteed. For more information, please contact us.

The Yealink CP925 Touch-Sensitive HD IP Conference Phone is expertly engineered for small to medium-sized meeting rooms. Available in new or refubished versions, it combines an understated, professional black acoustic fabric finish that resists accidental liquid spills with an intuitive 4-inch multi-touch capacitive screen, this conference phone delivers exceptional audio collaboration. Featuring built-in Wi-Fi, Bluetooth 4.2, and a powerful microphone array, it ensures seamless hybrid communication and crystal-clear vocal reproduction for every corporate meeting.

Modest Design, Easy to Use Interface

Designed for subtle elegance, the Yealink CP925 integrates into any meeting space. Its black acoustic fabric can realise crystal clear audio and is resistant to water, oil, and stains. Its ultra thin body, appropriate desktop fit, and ingenious hidden wiring slot, perfectly fit for the simple business style in the conference rooms. Additionally, its built in Linux system and easy to use UI interface, allow users to launch a meeting with one button and increase user adoption.

Sophisticated Technology

Diving into the field of audio communication for more than 20 years, Yealink has developed a series of acoustic technology including Smart Noise Filtering, Optimal HD audio and Noise Proof Technology to eliminate all the distracting sounds. Through next-generation technology, the exchange of verbal messages can be more productive than ever, ensuring every business discussion remains clear and focused.

First-Rate Audio Quality to Power up Communication

The audio performance of the CP925 is powered and enhanced by a built-in 7-microphone array dedicated to voice pickup and noise cancellation. Covering a 20-foot range with 360-degree omnidirectional reach, the hardware is fully equipped to deliver a clear and natural voice conference experience. Combined with full-duplex technology, smart noise filtering, and up to 320ms acoustic echo cancellation, background disturbances are actively suppressed to ensure lifelike audio fidelity.

Wireless Microphones

The Bluetooth expansion microphone CPW25 provides an extra 3-metre voice pickup range to expand the covering area of the CP925 without cord restraint.

Scalable for More Flexibility and Possibility - BYOD

By simply connecting the mobile devices (such as smart phone, PSTN device Yealink CPN10, etc.) to a CP925 via Bluetooth or USB, everyone can enjoy the premium audio for hybrid UC meetings (including PSTN, SIP, mobile phone). This transforms the unit into a robust bring-your-own-device (BYOD) audio peripheral for modern collaborative workspaces.

Features

  • Multi-Touch Screen - 4-inch multi-touch screen with 480x800 resolution
  • Audio Performance - Optimal HD audio, full duplex technology
  • Acoustic Filtering - Yealink Noise Proof Technology
  • Voice Pickup - 20-foot (6-metre) and 360-degree voice pickup
  • Microphone Array (Voice) -  Built-in 6-microphone array for voice pickup
  • Microphone Array (Noise) - Built-in 1-microphone array for noise cancellation
  • Power Options - Power over Ethernet
  • Conferencing Capacity -  5-way conference call
  • Collaboration Mode - Hybrid UC meeting
  • Wireless Networking - Built-in Wi-Fi (2.4GHz/5GHz, 802.11a/b/g/n)
  • Peripheral Linking - Built-in Bluetooth 4.2
  • Analogue Expansion - Local 3-way PSTN conference via Yealink CPN10

Audio Features

  • Optimal HD Audio
  • Yealink Noise Proof Technology
  • Smart Noise Filtering
  • 20ft (6 Metre)360° Voice Pickup Range
  • Ideal for Use in Small to Medium Conference Rooms
  • Built in 6 Microphone Array, 360° Voice Pickup
  • Built in 1 Microphone Array - Decrease Noise
  • Loudspeaker - Frequency - 100-20,000 Hz, Volume - 94dB at 0.5m Peak Volume
  • 56mm Diameter and 5w Speaker
  • Full Duplex Speakerphone with AEC
  • Echo Cancellation Tail Length is up tp 320ms
  • Background Noise Suppression
  • Codecs - G722, G722.1C, G726, G.729, G.729A, G723, iLBC, Opus, PCMU (G.711A), PCMA (G.711μ)
  • DTMF - In-Band, Out-of-Band (RFC 2833) and SIP INFO
  • VAD, CNG, PLC, AJB, AGC

Phone Features

  • 1 SIP Account
  • Call Hold, Mute, DND, Call Recording, Hotline
  • 5 Way Conference Call
  • Analog PSTN Calls via Yealink CPN10
  • Redial, Call Waiting, Emergency Call
  • Call Forward, Call Transfer, Call Return, Dial Plan
  • Ringtone Selection/Import/Delete
  • Set Date/Time Manually or Automatically
  • Volume Adjustment
  • Pairing via Bluetooth
  • Create Meeting Directly
  • Join Meeting Seamlessly
  • Active Speaker

Directory

  • Local Phonebook up to 1000 Entries
  • XML/LDAP Remote Phonebook
  • Intelligent Search Method
  • Phonebook Search/Import/Export
  • Call History - Dialed/Received/Missed/Forwarded
  • Block List

IP-PBX Features

  • Busy Lamp Field (BLF)
  • Multicast Paging
  • Intercom
  • Anonymous Call
  • Anonymous Call Rejection
  • Voicemail
  • Distinctive Ringtone
  • Call Pickup

Display

  • 4” 480x800 CapacitiveTouch Screen
  • Volume Key
  • Home Button

Interface

  • 1 x RJ45 10/100M Ethernet Port
  • Built-in Wi-Fi (2.4GHz/5GHz, 802.11a/b/g/n)
  • Built-in Bluetooth 4.
  • Power over Ethernet (IEEE 802.3af ), Class 3
  • 1 x USB 2.0 Type-C Device Port
  • 1 x Security Slot

Network and Security

  • SIP v1 (RFC2543), v2 (RFC3261)
  • SIP Server Redundancy Supported
  • NAT Traversal - STUN Mode
  • Proxy Mode and Peer-to-Peer SIP Link Mode
  • IP Assignment - Static/DHCP
  • HTTP/HTTPS Web Server
  • Time and Date Synchronisation using SNTP
  • UDP/TCP/DNS-SRV (RFC 3263
  • QoS - 802.1p/Q Tagging (VLAN), Layer 3 ToS, DSCP
  • SRTP for Voice Encryption
  • Transport Layer Security (TLS1.3)
  • HTTPS Certificate Manager
  • AES Encryption for Configuration File (AES256)
  • Adb Encryption Authenticated
  • Digest Authentication using MD5/MD5-sess
  • OpenVPN, L2TP VPN IPv4/IPv6
  • WPA2/WPA3 | Secure Boot
  • GARP (Generic Attribute Registration Protocol)

Management

  • Configuration - Browser/Phone/Auto-Provision/Yealink Device Management Platform
  • Auto Provision via FTP/TFTP/HTTP/HTTPS for Mass Deploy
  • Auto Provision with PnP
  • Zero-sp-Touch, TR-069
  • Reset to Factory, Reboot
  • Package Tracing Export, System Log

Standard Package Contents

  • Yealink CP925 IP Conference Phone
  • Ethernet Cable (7.5m CAT5E UTP Cable)
  • M2×5 Screw
  • Screwdriver
  • Quick Start Guide

*Please note - refurbished products package contents may vary from the above

More Information
Product Details
ColourBlack
Manufacturer's Code:CP925
Warranty12 months
ManufacturerYealink
Key Features
Room SizeSmall Meeting Room (3-5 users), Medium Room (6-12 users)
Recommended for up to this many users...10
Expandable with optional micsYes
Line TypeVoIP/SIP
If VoIP model - for use withStandard VoIP
Bluetooth CompatibleYes
Please Note
Please noteAll information is provided for reference only. If you are unsure about any of the features listed, please check the manufacturer's official information.
Write Your Own Review
Only registered users can write reviews. Please Sign in or create an account
Customer Questions
How do I stop echo during my video calls?

Echo is usually caused by audio from your speakers leaking back into your microphone. Our professional speakerphones feature "Full Duplex" audio and built-in Echo Cancellation (AEC) to eliminate this problem entirely.

Did you find what you were looking for?